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Preface

1. Document Conventions
This manual uses several conventions to highlight certain words and phrases and draw attention to
specific pieces of information.

In PDF and paper editions, this manual uses typefaces drawn from the Liberation Fonts1 set. The
Liberation Fonts set is also used in HTML editions if the set is installed on your system. If not,
alternative but equivalent typefaces are displayed. Note: Red Hat Enterprise Linux 5 and later includes
the Liberation Fonts set by default.

1.1. Typographic Conventions
Four typographic conventions are used to call attention to specific words and phrases. These
conventions, and the circumstances they apply to, are as follows.

Mono-spaced Bold

Used to highlight system input, including shell commands, file names and paths. Also used to highlight
keycaps and key combinations. For example:

To see the contents of the file my_next_bestselling_novel in your current
working directory, enter the cat my_next_bestselling_novel command at the
shell prompt and press Enter to execute the command.

The above includes a file name, a shell command and a keycap, all presented in mono-spaced bold
and all distinguishable thanks to context.

Key combinations can be distinguished from keycaps by the hyphen connecting each part of a key
combination. For example:

Press Enter to execute the command.

Press Ctrl+Alt+F2 to switch to the first virtual terminal. Press Ctrl+Alt+F1 to
return to your X-Windows session.

The first paragraph highlights the particular keycap to press. The second highlights two key
combinations (each a set of three keycaps with each set pressed simultaneously).

If source code is discussed, class names, methods, functions, variable names and returned values
mentioned within a paragraph will be presented as above, in mono-spaced bold. For example:

File-related classes include filesystem for file systems, file for files, and dir for
directories. Each class has its own associated set of permissions.

Proportional Bold

This denotes words or phrases encountered on a system, including application names; dialog box text;
labeled buttons; check-box and radio button labels; menu titles and sub-menu titles. For example:

Choose System → Preferences → Mouse from the main menu bar to launch Mouse
Preferences. In the Buttons tab, click the Left-handed mouse check box and click

1 https://fedorahosted.org/liberation-fonts/

https://fedorahosted.org/liberation-fonts/
https://fedorahosted.org/liberation-fonts/
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Close to switch the primary mouse button from the left to the right (making the mouse
suitable for use in the left hand).

To insert a special character into a gedit file, choose Applications → Accessories
→ Character Map from the main menu bar. Next, choose Search → Find… from the
Character Map menu bar, type the name of the character in the Search field and click
Next. The character you sought will be highlighted in the Character Table. Double-
click this highlighted character to place it in the Text to copy field and then click the

Copy button. Now switch back to your document and choose Edit → Paste from the
gedit menu bar.

The above text includes application names; system-wide menu names and items; application-specific
menu names; and buttons and text found within a GUI interface, all presented in proportional bold and
all distinguishable by context.

Mono-spaced Bold Italic or Proportional Bold Italic

Whether mono-spaced bold or proportional bold, the addition of italics indicates replaceable or
variable text. Italics denotes text you do not input literally or displayed text that changes depending on
circumstance. For example:

To connect to a remote machine using ssh, type ssh username@domain.name at
a shell prompt. If the remote machine is example.com and your username on that
machine is john, type ssh john@example.com.

The mount -o remount file-system command remounts the named file
system. For example, to remount the /home file system, the command is mount -o
remount /home.

To see the version of a currently installed package, use the rpm -q package
command. It will return a result as follows: package-version-release.

Note the words in bold italics above — username, domain.name, file-system, package, version and
release. Each word is a placeholder, either for text you enter when issuing a command or for text
displayed by the system.

Aside from standard usage for presenting the title of a work, italics denotes the first use of a new and
important term. For example:

Publican is a DocBook publishing system.

1.2. Pull-quote Conventions
Terminal output and source code listings are set off visually from the surrounding text.

Output sent to a terminal is set in mono-spaced roman and presented thus:

books        Desktop   documentation  drafts  mss    photos   stuff  svn
books_tests  Desktop1  downloads      images  notes  scripts  svgs

Source-code listings are also set in mono-spaced roman but add syntax highlighting as follows:

package org.jboss.book.jca.ex1;

import javax.naming.InitialContext;
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public class ExClient
{
   public static void main(String args[]) 
       throws Exception
   {
      InitialContext iniCtx = new InitialContext();
      Object         ref    = iniCtx.lookup("EchoBean");
      EchoHome       home   = (EchoHome) ref;
      Echo           echo   = home.create();

      System.out.println("Created Echo");

      System.out.println("Echo.echo('Hello') = " + echo.echo("Hello"));
   }
}

1.3. Notes and Warnings
Finally, we use three visual styles to draw attention to information that might otherwise be overlooked.

Note

Notes are tips, shortcuts or alternative approaches to the task at hand. Ignoring a note should
have no negative consequences, but you might miss out on a trick that makes your life easier.

Important

Important boxes detail things that are easily missed: configuration changes that only apply to
the current session, or services that need restarting before an update will apply. Ignoring a box
labeled 'Important' will not cause data loss but may cause irritation and frustration.

Warning

Warnings should not be ignored. Ignoring warnings will most likely cause data loss.

2. We Need Feedback!
If you find a typographical error in this manual, or if you have thought of a way to make this manual
better, we would love to hear from you! Please submit a report in JIRA against JBoss Developer
Studio: https://jira.jboss.org/jira/secure/CreateIssue.jspa?pid=12310500&issuetype=1

When submitting a bug report, be sure to mention the manual's name and to select the
"documentation" component.

If you have a suggestion for improving the documentation, try to be as specific as possible when
describing it. If you have found an error, please include the section number and some of the
surrounding text so we can find it easily.

https://jira.jboss.org/jira/secure/CreateIssue.jspa?pid=12310500&issuetype=1
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Introduction
The following chapters describe how to deal with classic/old style of JSF development. We
recommend users to use JBoss Seam to simplify development, but until then you can read about
classical JSF usage here.

Thus, in this document we are going to show you how to create a simple JSF application using JBoss
Tools plugins for Eclipse. The completed application will ask a user to enter a name and click a button.
The resulting new page will display the familiar message, "Hello <name>!" This tutorial will show you
how to create and run such an application from the beginning along the way demonstrating some of
the powerful features of JBoss Tools.

1.1. Key Features of JSF Tools
Here, we provide you with a key functionality which is integrated in JSF tooling.

Table 1.1. Key Functionality for JSF Tools

Feature Benefit

JSF and Facelets support Step-by-step wizards for creating new JSF and Facelets projects
with a number of predefined templates, importing existing ones
and adding JSF capabilities to non-jsf web projects.

Flexible and customizable
project template management

Jump-start development with out-of-the-box templates or easily
customized templates for re-use.

Support for JSF Configuration
File

Working on file using three modes: diagram, tree and source.
Synchronization between the modes and full control over the code.
Easy moving around the diagram using the Diagram Navigator.

Support for Managed Beans Adding new managed beans, generating code for attributes,
properties and getter/setter methods.

Support for Custom Converters
and Validators

Fast creating of custom converters and validators with tree view of
faces-config.xml file.

Verification and Validation All occuring errors will be immediately reported by verification
feature, no matter in what view you are working. Constant
validation and errors checking allows to catch many of the
errors during development process that significantly reduces
development time.

1.2. Other relevant resources on the topic
All JBoss Developer Studio/JBoss Tools release documentation you can find at http://docs.jboss.org/
tools1 in the corresponding release directory.

The latest documentation builds are available at http://download.jboss.org/jbosstools/nightly-docs2.

1 http://docs.jboss.org/tools/
2 http://download.jboss.org/jbosstools/nightly-docs/

http://docs.jboss.org/tools/
http://docs.jboss.org/tools/
http://download.jboss.org/jbosstools/nightly-docs/
http://docs.jboss.org/tools/
http://download.jboss.org/jbosstools/nightly-docs/
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Creating a Simple JSF Application
Firstly, we assume that you have already launched Eclipse with JBoss Tools plug-ins installed and
also that the Web Development perspective is the current one. (If not, make it active by selecting 
Window > Open Perspective > Web Development  from the menu bar or by selecting  Window > Open
Perspective > Other...  from the menu bar and then selecting  Web Development  from the Select
Perspective dialog box.)

2.1. Setting Up the Project
Now we are going to create a new project for the application.

• For that go to the menu bar and select  File > New > Project...

• Select  JBoss Tools Web > JSF > JSF Project  in the New Project dialog box

• Click  Next

• Enter "jsfHello" as the project name.

• Leave everything else as is, and click  Finish

2.2. JSF Configuration File
A jsfHello node should appear in the upper-left Package Explorer view.

Figure 2.1. Package Explorer View

• Click the plus sign next to  jsfHello  to reveal the child nodes

• Click the plus sign next to  WebContent  under jsfHello

• Click the plus sign next to  WEB-INF  under WebContent

• Then double-click on the faces-config.xml node to display the JSF application configuration file
editor
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Figure 2.2. Configuration File Editor
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Adding Navigation to the Application
In our simple application, the flow is defined as a single navigation rule connecting two views
(presentation files). At this point, we will create the placeholders for the two JSP presentation files
and then the navigation rule to connect them as views. Later, we will complete the coding for the JSP
presentation files. We can do all of this in the Diagram mode of the configuration file editor.

3.1. Adding Two Views (JSP Pages)
• Right-click anywhere on the diagram and select  New View...  from the pop-up menu

• In the dialog box, type  pages/inputname  as the value for From-view-id

• Leave everything else as is

• Click  Finish

If you look in the Package Explorer view you should see a  pages  folder under WebContent.
Opening it will reveal the JSP file you just created

• Back on the diagram, right-click anywhere and select  New View...  from the pop-up menu

• In the dialog box, type  pages/greeting  as the value for From-view-id

• Leave everything else as is

• Click  Finish

3.2. Creating the Transition (Navigation Rule)
• In the diagram, select the connection icon third from the top along the upper left side of the diagram

(  ) to get an arrow cursor with a two-pronged plug at the arrow's bottom.

• Click on the  pages/inputname  page icon and then click on the  pages/greeting  page icon

A transition should appear between the two icons.
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Figure 3.1. Transition Between Two Icons

• Select  File > Save  from the menu bar
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Adding a Managed Bean to the
Application
To store data in the application, we will use a managed bean.

• Click on the  Tree  tab at the bottom of the editing window

• Select the  Managed Beans  node and then click the  Add...  button displayed along the right side of
the editor window

• Type in  jsfHello.PersonBean  for Class and  personBean  for Name. Leave Scope as is and
Generate Source Code as is (checked)

• Click  Finish

• personBean will now be selected and three sections of information:  Managed Bean ,  Properties ,
and  Advanced , will be displayed about it. Under the Properties section, click the  Add...  button

• Type in  name  for Property-Name. Leave everything else as is. (When Property- Class is not filled
in, String is the assumed type)

• Click  Finish

• Select the  personBean  node in the tree

You should see this now:

Figure 4.1. Tree View in Config Editor

• Select  File > Save  from the menu bar

You have now registered the  managed bean  and created a  stub-coded class  file for it.
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Editing the JSP View Files
Now we will finish editing the JSP files for our two "views" using JSP Visual Page.

5.1. inputname.jsp
• Click on the  Diagram  tab for the configuration file editor

• Open the editor for this first JSP file by double-clicking on the  /pages/inputname. jsp  icon

The Visual Page Editor will open in a screen split between source code along the top and a WYSIWIG
view along the bottom:

Figure 5.1. Visual Page Editor

Some JSF code is already in the file, because we have chosen a template to create a page.

• Select the  Visual  tab, so we can work with the editor completely in its WYSIWYG mode

• To the right of the editor, in the JBoss Tools Palette, expand the  JSF HTML  palette folder by
selecting it
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Figure 5.2. JBoss Tools Palette

• Click on  form  within this folder, drag the cursor over to the editor, and drop it inside the red box in
the editor

• Another red box will appear inside the first red box

• Right-click on the innermost box and select  <h:form>  Attributes from the menu

• In the value field next to id, type  greeting  and click on the  Close  button

• Type "Please enter name:" inside the boxes

• Select  inputText  within the JSF HTML palette folder and drag it into the innermost box in the editor
after "Please enter name:"

• In the attributes dialog, click in the  value  field next to the value attribute and click on the ... button

• Then, select the  Managed Beans > personBean > name  node and click on the  Ok  button

• Back in the attributes dialog, select the  Advanced  tab, type in  name  as the value for the  "id" 
attribute, and then click on the  Finish  button

• Select  commandButton  within the JSF HTML palette folder and drag it into the innermost box in the
editor after the input box

• In the attributes dialog, click in the value field next to the  "action"  attribute and click on the ... button

• Then, select the  View Actions > greeting  node and click on the  OK  button
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• Back in the attributes dialog box, type in "Say Hello" as the value for the value attribute ("Say Hello")
and then click on the  Finish  button

The source coding should be something like this now:

<%@ taglib uri="http://java.sun.com/jsf/html" prefix="h" %>
<%@ taglib uri="http://java.sun.com/jsf/core" prefix="f" %>
<html>
<head>
<title></title>
</head>
<body>
<f:view>
<h:form id="greeting">
Please enter name:
<h:inputText id="name" value="#{personBean.name}"/>
<h:commandButton value=" Say Hello " action="greeting"/>
</h:form>
</f:view>
</body>
</html>

The editor should look like this:

Figure 5.3. Visual Page Editor

• Save the file by selecting  File > Save  from the menu bar

5.2. greeting.jsp
• Click on the  faces-config.xml  tab to bring the diagram back

• Open the editor for the second file by double-clicking on the  /pages/greeting.jsp  icon

• Select the  Visual  tab, so we can work with the editor completely in its WYSIWYG mode

• Type "Hello "(note space after Hello) into the box
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• Select  outputText  within the JSF HTML palette folder and drag it into the innermost box in the
editor after "Hello"

• In the attributes dialog, click in  value  field next to the value attribute and click on the ... (Browse)
button

• Then, select the  Managed Beans > personBean > name  node, click on the  Ok  button, and then
click on the  Finish  button

• Right after the output field, type an  exclamation point  ( ! )

The source coding should be something like this now:

<%@ taglib uri="http://java.sun.com/jsf/html" prefix="h" %>
<%@ taglib uri="http://java.sun.com/jsf/core" prefix="f" %>
<html>
<head>
<title></title>
</head>
<body>
<f:view>
Hello <h:outputText value="#{personBean.name}"/>!
</f:view>
</body>
</html>

• Save the file
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Creating the Start Page
You also need to create a start page as an entry point into the application.

• In the Package Explorer view to the left, right-click  jsfHello > WebContent  and select  New > JSP
File

• For Name type in  index , for Template select  JSPRedirect  and click  Finish

A JSP editor will open up on the newly created file.

• In the Source part of the split screen, type  /pages/inputname.jsf  in between the quotes for the page
attribute

The source coding should look like this now:

<!doctype html public "-//w3c//dtd html 4.0 transitional//en">
<html>
<head></head>
<body>
<jsp:forward page="/pages/inputname.jsf" />
</body>
</html>

Note the  .jsf  extension for the file name. This is a mapping defined in the web.xml file for the project
for invoking JavaServer Faces when you run the application.

• Select File > Save  from the menu bar



14



Chapter 7.

15

Running the Application
Everything is now ready for running our application by using the JBoss engine. For controlling JBoss
server there is JBoss Server view:

Figure 7.1. JBoss Server View

• Start up JBoss by clicking on the icon in JBoss Server view. (If JBoss is already running, stop it by
clicking on the red icon and then start it again. Remember, the JSF run-time requires restarting the
servlet engine when any changes have been made.) After the messages in the Console tabbed view
stop scrolling, JBoss is available

•
Click the Run icon(  ) or right click your project folder and select  Run As > Run on Server :

This is the equivalent of launching the browser and typing  http://localhost:8080/jsfHello  into your
browser. Our JSF application should now appear.
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Other Relevant Resources on the topic
JSF on Sun: JavaServer Faces Technology1

Core JSF: Core JavaServer Faces2

API: JSF API3

JSF Tags: JSF Core Tags4

HTML Tags Reference: JSF HTML Tags Reference5

JSF Central: JSF Central - Your JavaServer Faces Community6

FAQ: JSF FAQ7

Download: JavaServer Faces Technology - Download8

In summary, with this tutorial you should now know how to organize JSF sample application using the
wizards provided by JBoss Tools, configure its stuff and finally run it on the JBoss Server.

Find out more features on JSF tooling in our JSF Tools Reference Guide. If you have questions and
suggestions, please refer to JBoss Tools Forum9.

1 http://java.sun.com/javaee/javaserverfaces/
2 http://www.horstmann.com/corejsf/
3 http://java.sun.com/javaee/javaserverfaces/1.1/docs/api/index.html
4 http://www.horstmann.com/corejsf/jsf-tags.html
5 http://www.exadel.com/tutorial/jsf/jsftags-guide.html
6 http://www.jsfcentral.com/
7 http://wiki.java.net/bin/view/Projects/JavaServerFacesSpecFaq
8 http://java.sun.com/javaee/javaserverfaces/download.html
9 http://www.jboss.com/index.html?module=bb&op=viewforum&f=201

http://java.sun.com/javaee/javaserverfaces/
http://www.horstmann.com/corejsf/
http://java.sun.com/javaee/javaserverfaces/1.1/docs/api/index.html
http://www.horstmann.com/corejsf/jsf-tags.html
http://www.exadel.com/tutorial/jsf/jsftags-guide.html
http://www.jsfcentral.com/
http://wiki.java.net/bin/view/Projects/JavaServerFacesSpecFaq
http://java.sun.com/javaee/javaserverfaces/download.html
http://www.jboss.com/index.html?module=bb&op=viewforum&f=201
http://java.sun.com/javaee/javaserverfaces/
http://www.horstmann.com/corejsf/
http://java.sun.com/javaee/javaserverfaces/1.1/docs/api/index.html
http://www.horstmann.com/corejsf/jsf-tags.html
http://www.exadel.com/tutorial/jsf/jsftags-guide.html
http://www.jsfcentral.com/
http://wiki.java.net/bin/view/Projects/JavaServerFacesSpecFaq
http://java.sun.com/javaee/javaserverfaces/download.html
http://www.jboss.com/index.html?module=bb&op=viewforum&f=201
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Appendix A. Revision History
Revision 0 Fri Nov 20 2009 Isaac Rooskov irooskov@redhat.com

Initial creation of book by publican

mailto:irooskov@redhat.com
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