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概要

本書では、Red Hat CodeReady Studio のインストール、アップグレード、およびアンインストー
ルのプロセスについて説明します。
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多様性を受け入れるオープンソースの強化

Red Hat では、コード、ドキュメント、Web プロパティーにおける配慮に欠ける用語の置き換えに取り
組んでいます。まずは、マスター (master)、スレーブ (slave)、ブラックリスト (blacklist)、ホワイトリ
スト (whitelist) の 4 つの用語の置き換えから始めます。この取り組みは膨大な作業を要するため、今後
の複数のリリースで段階的に用語の置き換えを実施して参ります。詳細は、弊社 の CTO、Chris Wright
のメッセージ を参照してください。

多様性を受け入れるオープンソースの強化
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第1章 最小要件
CodeReady Studio 12.19 は、さまざまなオペレーティングシステム、アーキテクチャー、および Java
Development Kit の組み合わせと互換性があります。互換性の完全リストは「 Red Hat Fuse でサポー
トされる構成」および「コンポーネント 」を参照してください。

ハードウェア要件

2 GB の RAM

4 GB の RAM の使用を 強く 推奨します。

2 GB のハードディスク容量

ソフトウェア要件

OpenJDK がインストールされている。

Red Hat OpenJDK の使用を 強く 推奨します。

オペレーティングシステムの要件

For Linux (x86_64)

Red Hat Enterprise Linux 7 または 8

Fedora 31 または 32

Ubuntu 20.04 LTS または 19.10

Windows(x86_64)

Microsoft Windows 8 または 10

MacOS(x86_64)

Catalina (10.15) または Mojave (10.14)

注記

Windows で、すべてのユーザーが CodeReady Studio インスタンスを利用できるように
するには、すべてのユーザーがアクセスできるフォルダー (C:\codereadystudio) にイン
ストールします。指定のユーザーがこのメインのインストールフォルダーに書き込みで
きない場合は、新たにインストールされた機能や更新はそのユーザーのホームディレク
トリー内に保存されます。

Red Hat CodeReady Studio 12.19 インストールガイド
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第2章 OPENJDK のインストール
ここでは、Microsoft Windows および Red Hat Enterprise Linux (RHEL) に OpenJDK をインストールす
る方法を説明します。

2.1. WINDOWS での OPENJDK のインストール

MSI ベースのインストーラーを使用して OpenJDK 11 を Windows にインストールする方法を説明しま
す。

手順

1. Red Hat Developer Portal  から MSI ベースのインストーラーをダウンロードします。

2. インストーラーを実行し、画面のインストール手順にしたがいます。

3. 「Working with Java Runtime Environments」の手順にしたがって、CodeReady Studio が
OpenJDK を使用するように設定します。

2.1.1. その他のリソース

OpenJDK 11 のインストール方法の詳細は、『Installing and Using OpenJDK 11 for Windows 』を
参照してください。

2.2. RHEL での OPENJDK のインストール

RHEL に OpenJDK 11 をインストールする方法を説明します。

前提条件

Root 権限が必要です。

サブスクリプションがアタッチされた登録済みのシステム。
詳細は、『 システム登録およびサブスクリプション管理』を 参照してください。

手順

OpenJDK RPM をインストールするには、以下のコマンドを実行します。

# yum install java-11-openjdk-devel

任意で、java-11-openjdk-src および java-11-openjdk-demo パッケージをインストールできま
す。Java-11-openjdk-src パッケージには、IDE インデクサーおよびデバッガーと使用できる OpenJDK
11 クラスライブラリーのソースコードがすべて含まれています。java-11-openjdk-demo パッケージに
は、OpenJDK の Java ランタイム (デモおよび例) が含まれます。

java-11-openjdk-demo および java-11-openjdk-src をインストールするには、以下を実行しま
す。

# yum install java-11-openjdk-src java-11-openjdk-demo

トラブルシューティング

OpenShift クラスターへのログイン試行時に以下のエラーメッセージが発生した場合は、Java が

第2章 OPENJDK のインストール

5

http://developers.redhat.com/products/openjdk/overview/
https://help.eclipse.org/2019-12/index.jsp?topic=%2Forg.eclipse.jdt.doc.user%2Ftasks%2Ftasks-JREs.htm&cp%3D1_3_5
https://access.redhat.com/documentation/en-us/openjdk/11/html/installing_and_using_openjdk_11_for_windows/index
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html-single/configuring_basic_system_settings/index#assembly_registering-the-system-and-managing-subscriptions_configuring-basic-system-settings


OpenShift クラスターへのログイン試行時に以下のエラーメッセージが発生した場合は、Java が
TLSv1.2 を使用するように設定します。この問題は、Java 11.0.7 および OpenShift クラスター 4.4.0 以
降よりも前の Java JDK バージョンでのみ発生します。

Unable to execute request to request url https://<openshift-cluster-oauth-authorization-server>

TLSv1.2 を使用するよう Java を設定するには、以下を行います。

1. CodeReady Studio インストールディレクトリー内の studio ディレクトリーにある 
codereadystudio.ini ファイルを開きます。

2. -vmargs セクションに以下の行を追加します。

`-Djdk.tls.client.protocols=TLSv1.2`

2.2.1. その他のリソース

RHEL8 に並行してインストールされた 2 つの OpenJDK メジャーバージョンのインストール方
法、実行方法、切り替え方法は、「How to install Java 8 and 11 on Red Hat Enterprise Linux 8 」
を参照してください。

Red Hat CodeReady Studio 12.19 インストールガイド
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第3章 CODEREADY STUDIO のインストール
本章では、CodeReady Studio のインストール方法を説明します。

Eclipse を使用したインストール

インストーラーを使用したインストール

スクリプトを使用したインストール

ソースからのインストール

複数のバージョンの CodeReady Studio が異なるディレクトリーにあれば、インストーラーまたは
Eclipse を使用して複数のバージョンの CodeReady Studio をシステムにインストールできます。

3.1. ECLIPSE での CODEREADY STUDIO のインストール

Eclipse 用の CodeReady Studio は、既存の Eclipse インスタンスの CodeReady Studio プラグインを
パッケージ化します。
オンラインの状態であれば、Eclipse Marketplace から CodeReady Studio をインストールできます。こ
のインストール方法は、BYOE (Bring Your Own Eclipse) と呼ばれています。
オフラインの場合は、Update Site Zip を使用して CodeReady Studio をインストールできます。

次に、オンラインまたはオフラインの場合に CodeReady Studio をインストールする方法を説明しま
す。

3.1.1. Eclipse での CodeReady Studio のインストール (オンライン時)

Eclipse Marketplace から CodeReady Studio BYOE をインストールする方法を説明します。

手順

1. Eclipse IDE を起動します。

2. Help → Eclipse Marketplace をクリックします。

第3章 CODEREADY STUDIO のインストール
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Eclipse Marketplace ウィンドウが表示されます。

3. Locate Red Hat CodeReady Studio 12.19 GA.

Red Hat CodeReady Studio 12.19 インストールガイド
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4. Install をクリックします。

5. 画面の手順にしたがってインストールを完了します。

重要

インストールする追加機能を選択するプロンプトが表示されたら、インテグレー
ションアプリケーションの作成、テスト、およびデバッグを行う Fuse Tooling
機能を選択します。

署名なしコンテンツのインストールに関する警告を受け取った場合は、コンテンツの詳細を確
認し、問題がなければ Install Anyway をクリックしてインストールを続行します。

第3章 CODEREADY STUDIO のインストール
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6. Eclipse を再起動します。
Eclipse IDE を再起動するよう要求されたら、Restart Now をクリックします。Eclipse を再起
動するまで変更は反映されないため、注意してください。

3.1.2. Eclipse での CodeReady Studio のインストール (オフライン時)

ここでは、Update Site Zip で CodeReady Studio をインストールする方法を説明します。

前提条件

Red Hat Developer Portal から Red Hat CodeReady Studio 12.19 Update Site Zip をダウン
ロードします。

手順

1. Eclipse IDE を起動します。

2. Help → Install New Software をクリックします。

Available Software ウインドウが表示されます。

3. Add をクリックします。

Red Hat CodeReady Studio 12.19 インストールガイド
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Add Repository ウインドウが表示されます。

4. Archive をクリックし、Update Site Zip ファイルを見つけます。

5. Add をクリックします。

6. Red Hat CodeReady Studio - Bring Your Own Eclipse および Red Hat Fuse Tooling チェック
ボックスを選択します。

7. Next をクリックします。

8. 画面の手順にしたがってインストールを完了します。
署名なしコンテンツのインストールに関する警告を受け取った場合は、コンテンツの詳細を確
認し、問題がなければ Install Anyway をクリックしてインストールを続行します。

第3章 CODEREADY STUDIO のインストール
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9. Eclipse を再起動します。
Eclipse IDE を再起動するよう要求されたら、Restart Now をクリックします。Eclipse を再起
動するまで変更は反映されないため、注意してください。

3.2. インストーラーを使用した CODEREADY STUDIO スタンドアロンのイ
ンストール

インストーラーには、Eclipse の CodeReady Studio プラグインや依存するサードパーティープラグイ
ンをパッケージ化する CodeReady Studio スタンドアロンが含まれます。インストーラーはすべてのオ
ペレーティングシステムと互換性があり、Red Hat カスタマーポータルなどの複数のソースから入手で
きます。

ここでは、インストーラーを使用して CodeReady Studio をインストールする方法を説明します。

手順

1. Red Hat Developer Portal から Red Hat CodeReady Studio 12.19 Installer をダウンロードしま
す。

2. ダウンロードした codereadystudio-12.19.0.GA-installer-standalone.jar ファイルが含まれる
ディレクトリーに移動します。

3. インストーラーを起動します。

$ java -jar codereadystudio-12.19.0.GA-installer-standalone.jar

4. 画面の手順にしたがってインストールを完了します。

重要

インストールする追加機能を選択するプロンプトが表示されたら、インテグレー
ションアプリケーションの作成、テスト、およびデバッグを行う Fuse Tooling
機能を選択します。

Red Hat CodeReady Studio 12.19 インストールガイド
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3.3. 高度なインストールタスクの実行

次に、スクリプトを使用して CodeReady Studio をインストールする方法と、ソースコードから Red
Hat CodeReady Studio インストーラーをビルドする方法を説明します。

3.3.1. スクリプトを使用した Red Hat CodeReady Studio のインストール

次に、スクリプトを使用して CodeReady Studio をインストールする方法を説明します。

手順

1. Red Hat Developer Portal から Red Hat CodeReady Studio 12.19 Installer をダウンロードしま
す。

2. ダウンロードした codereadystudio-12.19.0.GA-installer-standalone.jar ファイルが含まれる
ディレクトリーに移動します。

3. インストーラーを起動します。

$ java -jar codereadystudio-12.19.0.GA-installer-standalone.jar

4. 画面の手順にしたがってインストールを完了します。

重要

インストールする追加機能を選択するプロンプトが表示されたら、インテグレー
ションアプリケーションの作成、テスト、およびデバッグを行う Fuse Tooling
機能を選択します。

インストールが完了すると、CodeReady Studio インストールディレクトリーに 
InstallConfigRecord.xml ファイルが生成されます。

第3章 CODEREADY STUDIO のインストール
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5. 以下のコマンドを実行します。

$ java -jar codereadystudio-12.19.0.GA-installer-standalone.jar \
  /path-to/InstallConfigRecord.xml

6. path-to を InstallConfigRecord.xml ファイルへのパスに置き換えます。

注記

生成された InstallConfigRecord.xml ファイルはマシン固有で、Java Development Kit
(JDK) およびシステムのインストールパスを使用します。他のオペレーティングシステ
ム、JDK、またはパスに InstallConfigRecord.xml ファイルを使用するには、このファ
イルを手作業で変更する必要があります。

3.3.2. CodeReady Studio スタンドアロンインストーラーをソースからビルド

CodeReady Studio スタンドアロンインストーラーをソースからビルドする方法を説明します。

前提条件

Maven 3.3 以降と Java 11 がインストールされている必要があります。Maven を取得および設定
するには、「Apache Maven Project」を参照してください。

手順

1. CodeReady Studio Git リポジトリーのクローンを作成します。

$ git clone https://github.com/jbdevstudio/jbdevstudio-product.git

2. jbdevstudio-product ディレクトリーに移動します。

$ cd jbdevstudio-product

3. master にチェックアウトします。

$ git checkout master

4. README.adoc ファイルの手順にしたがいます。

ビルドが完了すると、CodeReady Studio スタンドアロンインストーラーの .jar ファイルは 
/jbdevstudio-product/installer/target ディレクトリーに配置されます。

Red Hat CodeReady Studio 12.19 インストールガイド
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第4章 CODEREADY STUDIO のアップグレード
CodeReady Studio のバージョンを最新のメジャーおよびマイナーバージョンにアップグレードする可
能性について説明します。

4.1. CODEREADY STUDIO のメジャーバージョンのアップグレード

CodeReady Studio の各メジャーバージョンは、異なるバージョンの Eclipse をベースにしています。
そのため、古いメジャーバージョンの CodeReady Studio を、新しいメジャーバージョンにアップグ
レードすることはできません。たとえば、CodeReady Studio 10.x インストールを 11.x に更新すること
はできません。ただし、CodeReady Studio 12.x で CodeReady Studio 11.x を使用して作成したワークス
ペースを使用することは可能です。

複数のバージョンの CodeReady Studio が異なるディレクトリーにあれば、インストーラーまたは
Eclipse を使用して複数のバージョンの CodeReady Studio をシステムにインストールできます。

以下の表は、各メジャーバージョンの Red Hat CodeReady Studio でサポートされる Eclipse のバー
ジョンを示しています。

表4.1 Eclipse バージョンサポート一覧

Red Hat CodeReady Studio のバージョン ベースの Eclipse バージョン

CodeReady Studio 12.19 Eclipse IDE 2021-03

CodeReady Studio 12.18 Eclipse IDE 2020‑09

CodeReady Studio 12.17 Eclipse IDE 2020‑09

CodeReady Studio 12.16 Eclipse IDE 2020‑06

CodeReady Studio 12.15 Eclipse IDE 2020-03

CodeReady Studio 12.14 Eclipse IDE 2019‑12

CodeReady Studio 12.13 Eclipse IDE 2019‑09

CodeReady Studio 12.11 Eclipse SimRel 2019-03 GA

CodeReady Studio 12.9 Eclipse SimRel 2018-09 GA

CodeReady Studio 12.0 Eclipse 4.8 (Photon)

CodeReady Studio 11.x Eclipse 4.7 (Oxygen)

Red Hat CodeReady Studio 10.x Eclipse 4.6 (Neon)

Red Hat CodeReady Studio 9.x Eclipse 4.5 (Mars)

第4章 CODEREADY STUDIO のアップグレード
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4.2. RED HAT CODEREADY STUDIO のマイナーバージョンの更新

Red Hat CodeReady Studio を、メジャーリリースの最新のマイナーバージョンに更新することができ
ます。たとえば、Red Hat CodeReady Studio 12.0 インストールを 12.9 に更新できます。

自動更新の IDE 設定によっては、最新の Red Hat CodeReady Studio の更新が利用できるようになった
ときに IDE によって自動的に通知されます。

重要

更新する前にワークスペースをバックアップします。ワークスペースには、プロジェク
トファイルの他に、カスタマイズされた設定に関するメタデータや、IDE の設定が含ま
れます。ワークスペースをバックアップするには、ワークスペースディレクトリーを
バックアップする場所にコピーするか、圧縮ファイルとして保存します。

手順

1. Eclipse IDE を起動します。

2. Window → Preferences をクリックします。

Preferences ウィンドウが表示されます。

3. Install/Update → Available Software Sites を選択します。

Red Hat CodeReady Studio 12.19 インストールガイド

16



4. URL https://devstudio.redhat.com/12/stable/updates/ が有効な場所に表示されていることを
確認します。一覧にない場合は追加します。

5. Apply and Close をクリックします。

6. Help → Check for Updates をクリックします。

第4章 CODEREADY STUDIO のアップグレード
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更新の検索には時間がかかる場合があります。

7. 画面の指示に従って、利用可能な更新を適用します。
署名なしコンテンツのインストールに関する警告を受け取った場合は、コンテンツの詳細を確
認し、問題がなければ Install Anyway をクリックしてインストールを続行します。

8. Eclipse を再起動します。
Eclipse IDE を再起動するよう要求されたら、Restart Now をクリックします。Eclipse を再起
動するまで変更は反映されないため、注意してください。

Red Hat CodeReady Studio 12.19 インストールガイド
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第5章 CODEREADY STUDIO のアンインストール
Eclipse またはインストーラーを使用して CodeReady Studio をアンインストールする方法を説明しま
す。

複数のバージョンの CodeReady Studio が異なるディレクトリーにあれば、複数のバージョンの
CodeReady Studio をシステムにインストールできます。

5.1. ECLIPSE を使用した RED HAT CODEREADY STUDIO のアンインス
トール

Eclipse Marketplace または Update Site Zip でインストールされた CodeReady Studio のアンインス
トール方法を説明します。

手順

1. Eclipse IDE を起動します。

2. Help → Eclipse Marketplace をクリックします。

Eclipse Marketplace ウィンドウが表示されます。

第5章 CODEREADY STUDIO のアンインストール
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3. Installed セクションに移動します。

4. Red Hat CodeReady Studio を見つけます。

5. Change ボタンの近くにある下向き矢印をクリックします。

6. Uninstall をクリックします。
Confirm Selected Features ウインドウが表示されます。

Red Hat CodeReady Studio 12.19 インストールガイド
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7. Red Hat CodeReady Studio が選択されていることを確認します。

8. Confirm をクリックします。

9. Finish をクリックします。
Software Updates ダイアログボックスが表示され、Eclipse の再起動を要求されます。

10. Restart Now をクリックします。
Eclipse を再起動するまで変更は反映されないため、注意してください。

5.2. インストーラーを使用した CODEREADY STUDIO のアンインストール

インストーラーでインストールされた CodeReady Studio をアンインストールする方法を説明します。

手順

1. CodeReady Studio が実行されていないことを確認します。

2. /Uninstaller ディレクトリーに移動します。

$ cd /path-to/codereadystudio/Uninstaller

3. path-to を CodeReady Studio /codereadystudio/Uninstaller ディレクトリーへのパスに置き
換えます。

4. アンインストーラーを起動します。

$ java -jar uninstaller.jar

IzPack Uninstaller ダイアログボックスが表示されます。

5. Force the deletion チェックボックスを選択します。
このチェックボックスを選択しないと、一部のファイルがインストールディレクトリーに残さ
れます。

6. Uninstall をクリックします。

第5章 CODEREADY STUDIO のアンインストール
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第6章 問題の報告
JIRA でチケットを作成すると、エラーを報告できます。JIRA チケットを作成する場合は、JBDS また
は JBIDE プロジェクトのいずれかに対して作成してください。エラーをデバッグできるよう、JIRA チ
ケットにできるだけ細かく詳細を記入してください。また、JIRA チケットにエラーログを添付し、問
題の内容を提供することもできます。
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