搜索

第 1 章 安装 Red Hat Advanced Cluster Security for Kubernetes 的先决条件

download PDF

1.1. 常规要求

要安装 Red Hat Advanced Cluster Security for Kubernetes,您必须有:

  • OpenShift Container Platform 版本 4.5 或更高版本用于 OpenShift Container Platform 安装。

    警告

    您不能在以下环境中安装 Red Hat Advanced Cluster Security for Kubernetes:

    • Amazon Elastic File System(Amazon EFS)。使用带有默认 gp2 卷类型的 Amazon Elastic Block Store(Amazon EBS)。
    • 没有 SIMD 扩展 (SSE) 4.2 指令集的旧 CPU。例如,比 Sandy Bridge 和 AMD 处理器旧的 Intel 处理器(比 Bulldozer 旧)。(这些处理器在 2011 年发布。)
  • 具有受支持的操作系统的集群节点。如需更多信息,请参阅 Red Hat Advanced Cluster Security for Kubernetes 支持政策

    • 操作系统 :Amazon Linux、CentOS、Container-Optimized OS from Google、Red Hat Enterprise Linux CoreOS(RHCOS)、Debian、Red Hat Enterprise Linux(RHEL) 或 Ubuntu。
    • 处理器和内存 :2 个 CPU 内核和至少 3GiB RAM。

      注意

      对于部署中心,请使用带有 4 个或更多内核的机器类型,并应用调度策略在这样的节点上启动中心。

  • 使用持久性卷声明(PVC)的持久性存储。

    重要

    您不能在 Red Hat Advanced Cluster Security for Kubernetes 中使用 Ceph FS 存储。红帽建议为 Red Hat Advanced Cluster Security for Kubernetes 使用 RBD 块模式 PVC。

    • 使用固态驱动器(SSD)以获得最佳性能。但是,如果您没有 SSD,也可以使用另一个存储类型。
  • 如果您要使用 Helm chart 安装和配置 Red Hat Advanced Cluster Security for Kubernetes,则 Helm 命令行界面(CLI)v3.2 或更新版本。使用 helm version 命令验证已安装的 Helm 版本。
  • OpenShift Container Platform CLI (oc)。
  • 您必须具有在中心集群中配置部署所需的权限。
  • 您必须有权访问 Red Hat Container Registry。有关从 registry.redhat.io 下载镜像的详情,请参考 Red Hat Container Registry 身份验证
Red Hat logoGithubRedditYoutubeTwitter

学习

尝试、购买和销售

社区

关于红帽文档

通过我们的产品和服务,以及可以信赖的内容,帮助红帽用户创新并实现他们的目标。

让开源更具包容性

红帽致力于替换我们的代码、文档和 Web 属性中存在问题的语言。欲了解更多详情,请参阅红帽博客.

關於紅帽

我们提供强化的解决方案,使企业能够更轻松地跨平台和环境(从核心数据中心到网络边缘)工作。

© 2024 Red Hat, Inc.